Sie sind vermutlich noch nicht im Forum angemeldet - Klicken Sie hier um sich kostenlos anzumelden Impressum 
Sie können sich hier anmelden
Dieses Thema hat 26 Antworten
und wurde 3.101 mal aufgerufen
 LKWs
Seiten 1 | 2
Tobey Offline



Beiträge: 14

17.03.2019 22:26
#16 RE: Mercedes Benz Actros "Hansetrans" - Ein anderes Erstlingswerk... Zitat · Antworten

Hi Daniel,

schon faszinierend wie viel es da mittlerweile gibt...
Es ist ja auch nicht so das man da besonders viel können muss um das selbst zu implementieren aber es ist einfach schon bequemer wenn man nicht da ganz unten auch noch alles selbst machen muss von dem her - danke für den Hinweis! der Vorschlag mit dem M0 kam ja nun auch schon mal - vielleicht mach ich das fürs nächste projekt und kann nochmal kleiner werden.

Gelayoutet und geroutet hab ich alles mit kicad, nachdem mir eagle zu kompliziert war.
Auch der Tipp mit den footprints größer machen geht da aber die Treiber von mir haben leider nur auf der unterseite lötpads was es extrem schwer macht da ohne zusätzliche Hitzequelle was zu löten.
Wenn ich nicht im Büro qualifizierte Kollegen hätte, dann wär das in meinem Hobbykeller nichts geworden.
Mit ner Heißluftpistole und bisschen zubehör gehts aber auf jeden fall - wünsche dir schonmal viel erfolg!

danielk Offline



Beiträge: 19

18.03.2019 11:58
#17 RE: Mercedes Benz Actros "Hansetrans" - Ein anderes Erstlingswerk... Zitat · Antworten

Ich plane aktuell mit einem DRV8833, den gibt es handlötfreundlicher.
Wo lässt du die Platinen dann herstellen? Ich nehme easyeda, Layout-Tool und Herstellung quasi in einem.

Tobey Offline



Beiträge: 14

20.03.2019 06:54
#18 RE: Mercedes Benz Actros "Hansetrans" - Ein anderes Erstlingswerk... Zitat · Antworten

Hi Daniel,

das package sieht echt etwas besser aus was das Löten angeht.
Leider hat der aber auch ziemlich viele unnötige Füße was ihn dann wieder groß macht...
Mal schauen - ich glaub ich behalte meinen erstmal.

Wenn du mit easyEDA planst und Layoutest, kennst du meinen Platinenfertiger sicher auch ;)
JLCPCB

Viele Grüße, Tobias

Tobey Offline



Beiträge: 14

27.03.2019 22:27
#19 RE: Mercedes Benz Actros "Hansetrans" - Ein anderes Erstlingswerk... Zitat · Antworten

So mal wieder ein kleines Update...
Die Tests laufen ganz gut, ich kann nun alles steuern.
Das Layout passt soweit also schonmal.
Leider ist es mit dem motor so eine Sache.. wenn der ganz langsam läuft also gerade so über dem Anlaufstrom dann stürzt mir der Prozessor ab.
Läuft er dagegen mit voller pulle, dann kann ihn fast nichts stoppen.
Ich kann mir das noch nicht recht erklären. Wenn der treiber für vollgas genug Strom kriegt, müsste es für langsam eigentlich locker reichen.

Kennt sich jemand vielleicht etwas mit solchen phänomenen aus?

Falls alle stricke reißen, verbau ich einfach noch einen richtigen Motor treiber aber es würd mich schon interessieren, warum das jetzt nicht so recht funktionieren will zumal auf dem Treiber von populu (gleicher treiber IC) auch nicht mehr Bauteile daneben sind als auf meiner Platine (vielleicht ein etwas größerer Kondensator aber da hab ich mich ans Datenblatt gehalten).

Vielleciht hat von euch ja jemand einen Tipp.

Viele Grüße, Tobias

danielk Offline



Beiträge: 19

27.03.2019 22:34
#20 RE: Mercedes Benz Actros "Hansetrans" - Ein anderes Erstlingswerk... Zitat · Antworten

Hast du einen Oszillator, den du ranhängen könntest? Spannungseinbrüche oder sowas?
Wenn du eine LED statt dem Treiber an den PWM-Ausgang hängst, geht das dann?
Wie läuft es, wenn du den pololu-Treiber mal anklemmst, da müsstest du ja einfach die Pins nutzen können, oder?

michael93 Offline



Beiträge: 135

28.03.2019 07:03
#21 RE: Mercedes Benz Actros "Hansetrans" - Ein anderes Erstlingswerk... Zitat · Antworten

Zeig uns (oder mir per PN) doch mal Schaltplan und Layout. Die Renderings sehen so aus, als hättest du überhaupt keine Kapazitäten auf dem Design???

Hat deine H-Brücken-Ansteuerung ausreichende Totzeiten drin oder macht das der DRV selbst?

Grüße, Michael

Tobey Offline



Beiträge: 14

28.03.2019 07:42
#22 RE: Mercedes Benz Actros "Hansetrans" - Ein anderes Erstlingswerk... Zitat · Antworten

Hi Zusammen, den pololu treiber hab ich noch nicht. ich werde jetzt dieses Wochenende mal probieren über einen servo controller den Motor direkt mit PWM zu steuern.
Mit einer LED geht es. Es kommt mir so vor als ob bei geringer Spannung irgendwas seltsames passiert. Die Treiber machen soweit alles selbst, da steht nur man soll PWM reinhauen und dann kommt getriebenes Signal raus mit 1,2A Imax.
Die Renderings sind etwas älter. Ich stelle heute Abend mal aktuelle Bilder hier rein und kann auch mal den Schaltplan posten. Da sind keine Geheimnisse drauf. Ist ja alles mehr oder weniger direkt an den µC verbunden.
Ich habe die vorgeschriebenen 0,1µF an VCC und VM der Treiber. Den Bulk Kondensator hatte ich vergessen aber den hab ich nun einfach zwischen VCC am Board angelötet. Damit wurde es dann zwar besser aber richtig gelöst ist das Problem nicht.

Wir werden sehen - danke schonmal für euer interesse.
Ich hoffe ich vergesse nicht zu posten

danielk Offline



Beiträge: 19

28.03.2019 15:32
#23 RE: Mercedes Benz Actros "Hansetrans" - Ein anderes Erstlingswerk... Zitat · Antworten

Und wenn dein Microcontroller hängen bleibt, hast du für den die passenden Stützkondensatoren eingebaut?
Bin schon sehr auf dein Design gespannt.

Tobey Offline



Beiträge: 14

28.03.2019 22:45
#24 RE: Mercedes Benz Actros "Hansetrans" - Ein anderes Erstlingswerk... Zitat · Antworten

So... leider etwas spät aber hier ist noch der Schaltplan :)


Was hier jetzt nich drauf is, ist der Elko am VCC den ich noch dran gelötet habe.
Das einzige was ich vergessen hab sind elkos direkt am Treiber,... das werd ich nächste Woche mal im Büro mit meinem kollegen am Oszilloskop rausmessen bzw. dann welche dranfädeln und schauen obs besser wird.

Ich hab vorsorglich mal 10 9g Servos bestellt um die wegen der PWM controller zu zerlegen.
Momentan sieht meine Motorsteuerung so aus


Ein kaputtes 6g Servo von dem ich mir die Platine gemopst hab. Hat aus Programmierer sicht auch Vorteile da vorwärts/rückwärts direkt funktioniert.

Falls ich die Treiber nicht hinbekomme, designe ich die weg, spar ein bisschen Platz ein und machs erstmal mit Servo Platinen...
schöner wär allerdings die all-in-one Lösung aber ich bin langsam ziemlich genervt
Wollte es schon paar mal nun einfach mal paar Tage liegen lassen aber ich kanns dann doch auch nicht lassen weiter zu experimentieren.

Vielleicht habt ihr ja noch eine Idee :)

Viele Grüße, Tobias|addpics|nmr-f-cf21.png,nmr-g-e0c9.jpeg-invaddpicsinvv|/addpics|

michael93 Offline



Beiträge: 135

31.03.2019 11:07
#25 RE: Mercedes Benz Actros "Hansetrans" - Ein anderes Erstlingswerk... Zitat · Antworten

Hi,

also in deinem Schaltplan fehlen definitiv die 100nF Abblockkondensatoren direkt am ATMega. Hab mir jetzt das Pinning nicht angeschaut, aber oft liegen VDD und GND auf nebeneinander liegenden Pins. Da bekommst du evtl. jeweils einen 0402-100nF dazwischen gelötet.

Zusätzlich hilft es bestimmt auch, wenn du direkt an den Treibern VM nochmal ordentlich abblockst, so mit mindestens 1uF, besser 10uF. Gibts ja auch in 0603 für die geringe Betriebsspannung.

Ist R7 (Reset Pull-Up) tatsächlich nicht bestückt? Den mit ca. 1-10 kOhm zu bestücken könnte auch helfen.

Benutzt du eigentlich 4 Motorausgänge oder schaltest du die Ausgänge eines Treibers parallel?

Grüße, Michael

Tobey Offline



Beiträge: 14

01.04.2019 06:51
#26 RE: Mercedes Benz Actros "Hansetrans" - Ein anderes Erstlingswerk... Zitat · Antworten

Hi Michael!

danke für die guten Tipps. ich werde das morgen mal ausprobieren.
Das mit Gnd und VCC stimmt. Ich muss mal sehen, glaube die pins sind zu eng um direkt aufzulegen aber kann man ja mit kurzem draht fädeln.

Die Treiber sind mal als 4 x 1 Motor gedacht, wobei einer gerade eh nicht geht weil für die Servo Ansteuerung in PWM Timer benötigt wird.
Momentan kann ich also 3 Motoren (VW/RW) und 8 Servos ansteuern.

Viele Grüße, Tobias

Tobey Offline



Beiträge: 14

10.04.2019 18:14
#27 RE: Mercedes Benz Actros "Hansetrans" - Ein anderes Erstlingswerk... Zitat · Antworten

Hallo Zusammen,

ich melde mich mal wieder zurück und habe sogar gute Nachrichten (zumindest für mich)
Der Tipp mit den 10µF Kondensatoren war super.

Es ist etwas doof... ich habe das DRV Datenblatt nicht ganz gelesen und im einen Diagramm sind nur die 0,1µF Kondensatoren und keine weiten gezeichnet. Weiter unten steht dann das man noch die Bulk Kondensatoren braucht, welche ich leider vergessen habe.

5 µF hat da schon gut geholfen ich habe nun 10 an VMM und VCC des DRV und nun läuft er sehr robust. Meinem µC habe ich nun sicherheitshalber auch noch 10µF an VCC spendiert und den R7 mit 10kOhm bestückt.

Einen weiteren Layoutfehler hat mein Hardwerker entdeckt. Nämlich ist mein TX pin vom µC falsch an den Spannungsteiler angeklemmt .... Da bei PCB die Layouts gereade günstig sind, kann ich das direkt mit reinplanen.

Ich werde demnächst mal wieder ein paar Bilder posten, wenn es mit dem eigentlichen LKW dann weiter geht.

Viele Grüße, Tobias

Seiten 1 | 2
 Sprung  

Xobor Forum Software von Xobor
Einfach ein eigenes Forum erstellen
Datenschutz