Sie sind vermutlich noch nicht im Forum angemeldet - Klicken Sie hier um sich kostenlos anzumelden Impressum 
Sie können sich hier anmelden
Dieses Board hat 1.751 Mitglieder
48.928 Beiträge & 5.249 Themen
Beiträge der letzten Tage
Foren Suche
Suchoptionen
  • Foren-Beitrag von Tobey im Thema

    Hallo Zusammen,

    ich melde mich mal wieder zurück und habe sogar gute Nachrichten (zumindest für mich)
    Der Tipp mit den 10µF Kondensatoren war super.

    Es ist etwas doof... ich habe das DRV Datenblatt nicht ganz gelesen und im einen Diagramm sind nur die 0,1µF Kondensatoren und keine weiten gezeichnet. Weiter unten steht dann das man noch die Bulk Kondensatoren braucht, welche ich leider vergessen habe.

    5 µF hat da schon gut geholfen ich habe nun 10 an VMM und VCC des DRV und nun läuft er sehr robust. Meinem µC habe ich nun sicherheitshalber auch noch 10µF an VCC spendiert und den R7 mit 10kOhm bestückt.

    Einen weiteren Layoutfehler hat mein Hardwerker entdeckt. Nämlich ist mein TX pin vom µC falsch an den Spannungsteiler angeklemmt .... Da bei PCB die Layouts gereade günstig sind, kann ich das direkt mit reinplanen.

    Ich werde demnächst mal wieder ein paar Bilder posten, wenn es mit dem eigentlichen LKW dann weiter geht.

    Viele Grüße, Tobias

  • Foren-Beitrag von Tobey im Thema

    Hi Michael!

    danke für die guten Tipps. ich werde das morgen mal ausprobieren.
    Das mit Gnd und VCC stimmt. Ich muss mal sehen, glaube die pins sind zu eng um direkt aufzulegen aber kann man ja mit kurzem draht fädeln.

    Die Treiber sind mal als 4 x 1 Motor gedacht, wobei einer gerade eh nicht geht weil für die Servo Ansteuerung in PWM Timer benötigt wird.
    Momentan kann ich also 3 Motoren (VW/RW) und 8 Servos ansteuern.

    Viele Grüße, Tobias

  • Foren-Beitrag von Tobey im Thema

    So... leider etwas spät aber hier ist noch der Schaltplan :)


    Was hier jetzt nich drauf is, ist der Elko am VCC den ich noch dran gelötet habe.
    Das einzige was ich vergessen hab sind elkos direkt am Treiber,... das werd ich nächste Woche mal im Büro mit meinem kollegen am Oszilloskop rausmessen bzw. dann welche dranfädeln und schauen obs besser wird.

    Ich hab vorsorglich mal 10 9g Servos bestellt um die wegen der PWM controller zu zerlegen.
    Momentan sieht meine Motorsteuerung so aus


    Ein kaputtes 6g Servo von dem ich mir die Platine gemopst hab. Hat aus Programmierer sicht auch Vorteile da vorwärts/rückwärts direkt funktioniert.

    Falls ich die Treiber nicht hinbekomme, designe ich die weg, spar ein bisschen Platz ein und machs erstmal mit Servo Platinen...
    schöner wär allerdings die all-in-one Lösung aber ich bin langsam ziemlich genervt
    Wollte es schon paar mal nun einfach mal paar Tage liegen lassen aber ich kanns dann doch auch nicht lassen weiter zu experimentieren.

    Vielleicht habt ihr ja noch eine Idee :)

    Viele Grüße, Tobias|addpics|nmr-f-cf21.png,nmr-g-e0c9.jpeg-invaddpicsinvv|/addpics|

  • Foren-Beitrag von Tobey im Thema

    Hi Zusammen, den pololu treiber hab ich noch nicht. ich werde jetzt dieses Wochenende mal probieren über einen servo controller den Motor direkt mit PWM zu steuern.
    Mit einer LED geht es. Es kommt mir so vor als ob bei geringer Spannung irgendwas seltsames passiert. Die Treiber machen soweit alles selbst, da steht nur man soll PWM reinhauen und dann kommt getriebenes Signal raus mit 1,2A Imax.
    Die Renderings sind etwas älter. Ich stelle heute Abend mal aktuelle Bilder hier rein und kann auch mal den Schaltplan posten. Da sind keine Geheimnisse drauf. Ist ja alles mehr oder weniger direkt an den µC verbunden.
    Ich habe die vorgeschriebenen 0,1µF an VCC und VM der Treiber. Den Bulk Kondensator hatte ich vergessen aber den hab ich nun einfach zwischen VCC am Board angelötet. Damit wurde es dann zwar besser aber richtig gelöst ist das Problem nicht.

    Wir werden sehen - danke schonmal für euer interesse.
    Ich hoffe ich vergesse nicht zu posten

  • Foren-Beitrag von Tobey im Thema

    So mal wieder ein kleines Update...
    Die Tests laufen ganz gut, ich kann nun alles steuern.
    Das Layout passt soweit also schonmal.
    Leider ist es mit dem motor so eine Sache.. wenn der ganz langsam läuft also gerade so über dem Anlaufstrom dann stürzt mir der Prozessor ab.
    Läuft er dagegen mit voller pulle, dann kann ihn fast nichts stoppen.
    Ich kann mir das noch nicht recht erklären. Wenn der treiber für vollgas genug Strom kriegt, müsste es für langsam eigentlich locker reichen.

    Kennt sich jemand vielleicht etwas mit solchen phänomenen aus?

    Falls alle stricke reißen, verbau ich einfach noch einen richtigen Motor treiber aber es würd mich schon interessieren, warum das jetzt nicht so recht funktionieren will zumal auf dem Treiber von populu (gleicher treiber IC) auch nicht mehr Bauteile daneben sind als auf meiner Platine (vielleicht ein etwas größerer Kondensator aber da hab ich mich ans Datenblatt gehalten).

    Vielleciht hat von euch ja jemand einen Tipp.

    Viele Grüße, Tobias

  • Foren-Beitrag von Tobey im Thema

    Hi Daniel,

    das package sieht echt etwas besser aus was das Löten angeht.
    Leider hat der aber auch ziemlich viele unnötige Füße was ihn dann wieder groß macht...
    Mal schauen - ich glaub ich behalte meinen erstmal.

    Wenn du mit easyEDA planst und Layoutest, kennst du meinen Platinenfertiger sicher auch ;)
    JLCPCB

    Viele Grüße, Tobias

  • Foren-Beitrag von Tobey im Thema

    Hi Daniel,

    schon faszinierend wie viel es da mittlerweile gibt...
    Es ist ja auch nicht so das man da besonders viel können muss um das selbst zu implementieren aber es ist einfach schon bequemer wenn man nicht da ganz unten auch noch alles selbst machen muss von dem her - danke für den Hinweis! der Vorschlag mit dem M0 kam ja nun auch schon mal - vielleicht mach ich das fürs nächste projekt und kann nochmal kleiner werden.

    Gelayoutet und geroutet hab ich alles mit kicad, nachdem mir eagle zu kompliziert war.
    Auch der Tipp mit den footprints größer machen geht da aber die Treiber von mir haben leider nur auf der unterseite lötpads was es extrem schwer macht da ohne zusätzliche Hitzequelle was zu löten.
    Wenn ich nicht im Büro qualifizierte Kollegen hätte, dann wär das in meinem Hobbykeller nichts geworden.
    Mit ner Heißluftpistole und bisschen zubehör gehts aber auf jeden fall - wünsche dir schonmal viel erfolg!

  • Foren-Beitrag von Tobey im Thema

    Hi Michael,

    ok dann poste ich einfach immer wieder mal etwas
    Ich habe es nochmal mit bleihaltigem Lötzinn probiert und das hat dann prima geklappt.
    Das bleifreie wollte einfach nciht richtig aufschmelzen.
    Ich denke für die "Serienfertigung" also alles über 5 Modulen, probier ich es mit Lötpaste und einem Reflow Ofen der hier in der nähe wohnt.

    Momentan habe ich aber eine funktionierende Platine vor mir, welche munter blinkt und sowohl motoren als auch Servos steuert - also ein kleiner Erfolg! Nächster test wird das BLE Modul.

    Da mein Microcontroller allerdings nur 3 Timer hat verliere ich eh 2 PWM Ausgänge, außer ich modelliere sie über soft-pwm.
    Somit kann ich aktuell 3 Motoren mit vorwärts rückwärts ansteuern (statt 4).
    Das wird für mein aktuelles Projekt locker reichen, für den Bagger / Radlader zu meinem Kipper muss ich mal schauen.
    Servos sind momentan max. 6 möglich.

    Ich spreche direkt BLE also habe die Service struktur auf Android programmiert und auch Module die nur das sprechen.
    Das seriel wäre zwar deutlich einfacher, wenn mans aber mal hat machts auch keinen unterschied.
    Das einzige Problem ist, dass das BLE bei mir irgendwie anders updated und deshalb das servo noch nicht so smooth ist wie beim BL 2.0.
    Da komm ich aber vermutlich hin, wenn ich nochmal an meine interrupt routinen ran gehe.

    Der Tipp mit der Lötpaste ist echt gut. Das probier ich bei der nächsten mal aus.
    Hab für die ketzige aber leider keine Schablone.
    Bastelst du dir das selbst?

    Jetzt hoff ich mal das ich meinen prototyp nicht abschieße... ich hab momentan keine Treiber ICs mehr

  • Foren-Beitrag von Tobey im Thema

    So... ich weiß zwar nciht obs jemanden interessiert, aber ich "blogge" mal meinen aktuellen Status

    Ich habe die platinen mit dem DRV8835 bestückt also insgesamt Plätze für 4 Motoren. Die Platinen kamen letzte Woche an also konnte ich Bestücken. Leider sind die DRV8835 in nem echt blöden package um sie von hand zu löten und so haben wir versucht sie an zu föhnen. das hat auch funktioniert, die Bauteile sind fixiert. Leider hat aber die funktionsprüfung ergeben, dass iergendwas schief gelaufen ist... nächste woche probieren wir es nochmal.

    Ansonsten bin ich recht zufrieden mit meinem Status.
    Der Kipper mit Zugmaschine von Max Wild ist nun lenkbar und der Motor ist auch mal grob verbaut. Das einbauen der Herpa Lenkungsteile bei einem Herpa LKW ist schon viel einfacher als beim Wiking Modell mit der von Sol expert. Allerdings is die Pendelachse schon auch toll.. naja mal sehen was ich dann im nächsten Modell verbaue.

    Ich habe nun nach Sitzprobe von Akku und Bluetooth Modul im Fahrerhaus noch genug Platz für die eigenbau Platine. Die passt in das Volvo Fahrerhaus deutlich luftiger rein als in das vom Actros. Eventuell besorge ich noch einen 12 Mhz quarz statt dem 16er dann kann ich den LKW auch komplett aus der einen Lipo Zelle versorgen und muss kein step up regulator mehr verbauen - das wird dann die Zukunft zeigen.

    Auch der Code ist nun getestst und funktioniert sowohl mit BLE als auch mit den normalen BL Modulen.
    Auf dem Atmega 1284p hab ich mal erste Tests gemacht, die auch ganz gut aussahen.

    Soweit von mir und bis bald

    hab leider gerade keine Kamera am handy, bzw die Linse ist kauptt aber ein paar unscharfe impressionen häng ich euch an |addpics|nmr-d-ef7b.jpg,nmr-e-3c41.jpg|/addpics|

  • Foren-Beitrag von Tobey im Thema

    Hi Michael,

    das klingt ja wirklich interessant.
    ich werde mir das mal genauer ansehen.
    Bin jetzt am Wochenende mal zum spielen gekommen und habe meine BLE Module angelötet.
    Hab dann nun die App auf BLE angepasst und kann nun mein normales BT ansprechen und eben das BLE Modul verwenden.
    Dieses BLE Zeug ist wirklich ziemlich sperrig verglichen mit dem normalen Bluetooth. Allein das ganze drum herum hat mich nun einige Stunden an Coding gekostet.
    Aber das Ergebnis zählt und die lampe leuchtet... jetzt muss ich noch meinen Arduino Code umschreiben dann kann ich das Layout testen und meine Platinen bestellen. :)

    Freue mich wenn du ein Update zu deinen Bemühungen postest.

    Viele Grüße, Tobi

  • Foren-Beitrag von Tobey im Thema

    hey Zusammen,

    ist ja Fancy der BMD... das erinnert mich ein Wenig an den Microchip RN42 nur mit mehr offenen pins.
    Das größte Problem wird da vmtl sein die Firmware zu haben, bzw um den BLE Stack herum die eigene Applikation einzubauen.
    Auch hab ich ein wenig Respekt vor dem Cortex. Das ist meiner Einschätzung nach doch ne andere Nummer was den Programmieraufwand angeht. Außerdem bin ich mit Microcontrollern nciht ganz so fit wie ichs gern wär... mein jetziges Board mit Arduino zu schreiben war z. B. eher einfach, weil ich mich nicht um diese ultra-low Level Hardware Schicht gekümmert habe.
    Aber fürs nächste Projekt könnte man das durchaus mal probieren...
    Weißt du wo man an den Stack fürs BLE kommt?
    Was mich an BLE stört, ist das es auch schon wieder aufwändiger zu programmieren ist. die normale 2.0 Geschichte ist dagegen ja lächerlich einfach. Aber ich werde das jetzt mal anschließen und dann Berichten.

    Hab jetzt mal zum Spaß den Atmega im DIL Gehäuse geordert und bau das alles mal auf meinem Steckbrett auf. Flashen versuche ich mal mit meinem Arduino dann brauch ich keinen ISP.

    Ich werd mal die Zugmaschine ebstellen und schauen ob die 22x22 da ins Führerhaus passen.

    Danke für den Tipp mit den Motor treiber ICs! Die sehen ja echt klasse aus! mal sehn ob ich die noch unter bringe. Dann könnte ich 4 statt 2 Motoren das wär ja schonmal richtig super. Müsste dann nur dickere Leiterbahnen verwenden damit mir nich die 1mm Tracks druchbrennen

    Ich hab jetzt da das 44 Pin SMD gehäuse... müsste mal schauen wie viel kleiner es den Atmega 1284p noch gibt.. dachte eigentlich es gibt die zwei. Ich glaub darunter wirds auch mit dem Löten eher ne zittrige aufgabe oder?

    Viele Grüße, Tobi

  • Foren-Beitrag von Tobey im Thema

    Hi Michael,

    vielen Dank für deine Nachricht.
    Ja das mit dem Stromverbrauch stimmt. Ruhestrom ist etwas um die 100mA - also wenn kein licht und kein Motor läuft.
    Allerdings hab ich ein digitalservo verbaut. Ich glaube wenn man da richtig sparen muss, sollte man das analog lassen aber das weiß ich nciht so sicher.

    Als modul hatte ich noch ein HC-06 Modul rumliegen das ich vor einigen Jahren mal gekauft habe um eine lampe zu steuern aber das Projekt ist nie was geworden. Darum hab ich das jetzt erstmal genommen.
    Ich habe bereits einige Bluetooth BLE Module rumliegen aber ich hab es noch nicht geschafft mich damit näher auseinander zu setzen. Die haben auch noch keine Pinleiste dran drum ist es etwas kniffelig da mit dem µC dran zu gehen. Dazu sind die meist auch noch 3,3V und der µC 5. Ich werde mir da noch ein paar kleine Festpsannungsregler besorgen müssen

    Für das nächste Projekt habe ich nun übers Wochenende mal ein bisschen rumgespielt...
    Wie ist eure Erfahrung so.. sind die 20x20mm des Deltang empfängers gut zu verbauen oder ist das schon zu groß?
    Ich hab jetzt mal ein PCB designed und geroutet und werde das wohl mal ordern und mein nächstes Projekt dann mit Bluetooth Low Energy und nem etwas stärkeren Atmega basteln...
    Designed sind jetzt mal 2 Motor ports (vorwärts/rückwärts) und 4 Servo Ports.
    Das Problem ist ich weiß nicht wie die bei Deltang die 600mA regler so klein auf die Platine bekommen...
    Kleiner als 22x22mm werd ich einfach nicht.





    Vielleicht geht unten noch einer drauf... Ich glaube für meinen geplanten bagger brauch in min. 3
    Wie viele Motoren braucht Ihr so in euren Projekten?


    Viele Grüße, Tobi|addpics|nmr-b-5e1f.png,nmr-c-4cd6.png-invaddpicsinvv|/addpics|

  • Foren-Beitrag von Tobey im Thema

    Hey Maik,
    ja das war auch erst meine Sorge und Anfangs hatte ich da auch einige Herausforderungen zu lösen.
    Das Problem war jedoch das alle fertigen Fernbedienungen bzw. deren protokolle so viele unnötige Bytes versendet haben,
    das die Standard Datenrate in meinem möglichen setup knapp geworden wäre bzw. der Controller nurnoch mit auslesen beschäftigt wäre.
    Da ich einen sehr spezeillen use-case habe, konnte ich das Protokoll sehr schlank halten und nur wenige bytes pro commando verwenden.
    Es gibt kein merkbares delay zwischen absenden und umsetzen.
    Auf jedenfall unter einer halben Sekunde

    an Sebastian:
    Ich bin mir nciht sicher aber ich glaube das bluetooth protokoll basiert auf einer 1:1 Verbindung.
    Ich habe erst vor kurzem erfahren bzw. gelesen, dass viele hier mehrere Empfänger auf den selben "Kanal" binden. Dass das geht wusste ich gar nicht. Ich muss mal schauen, wie die limitierungen zuschlagen, wenn ich etwas mit Auflieger bauen will und nciht über Steckkontakte die Daten durchschleifen will.

    Mir ging es bei der Verwendung mehr um das sehen ob ich es sinnvoll hinkriege als darum möglichst schnell fertig zu werden. Ein großer Vorteil ist natürlich das jeder mit einem Smartphone und meiner app mitspielen kann ohne das man eine Fernsteuerung braucht. Auch die Reichweite ist erstaunlich. 10 meter sind locker drin... darüber testen ging nciht - meine Wohnung ist zu klein. Aber klar.. an die Haptik und Bedienung einer richtigen RC anlage kommt es nicht ran und vmtl wird sich auch noch ein Deltang in eines meiner nächsten Modelle finden vllt. ein Bagger...


    Grüße, Tobi

  • Thema von Tobey im Forum LKWs

    Hallo Zusammen,
    mein Name ist Tobi und ich bin durch Zufall auf einer Messe auf das Thema Mikromodellbau aufmerksam geworden.
    Ich mag die kleinen bagger und LKW und da die in klein auch zum spielen gut taugen,
    wollte ich mich auch mal an dem Thema versuchen.
    Ich muss gestehen ich habe das Thema unterschätzt aber zum Glück hatte ich einen Flyer von 1zu87 Modellbau von einer Messe mitgenommen, somit hatte ich immerhin eine erste Bezugsadresse.

    Immer um Weihnachten kommt bei mir die Zeit in der ich mir ein neues Projekt suche. Normalerweise komme ich aus dem Funktionsmodellbau mit Flugzeugen und Hubschraubern aber ein solches kleines "Spielzeug" würde sehr gut in meine Sammlung passen.

    Ich hatte nur kurz recherchiert und mir ein paar Videos vom Theoretiker angesehen und dann direkt einen eigenen LKW bestellt. Einen Actros Gliederzug der Firma "Hansetrans" von Wiking. Ich war zwar erst skeptisch was das Aussehen anging aber es gab gerade keinen schöneren Gliederzug und ein solcher sollte es werden, da ich mir nicht sicher war wie gut ich beim ersten Werk alles ins Fahrerhaus bekomme.

    Hier die Grundbeleuchtung:


    Was macht dieses Projekt anders?
    Schnell habe ich die nötigen Infos gehabt, was die Empfänger etc. anging.
    Ich wollte jedoch etwas anderes machen. Das Modell sollte über Bluetooth mit einer Handy Fernsteuerung steuerbar sein.
    Das hatte einige Vorteile, jedoch auch eine Menge Nachteile.
    Einige Vorteile sind, dass ich nun damit im Büro spielen kann und nur mein Handy und das Modell brauche, die lichter steuern kann wie ich es will und auch sonst viele Freiheiten bei der gestaltung habe.
    Die Nachteile sind u. A. das die fertigen Module für DSM viel kleiner sind und ich deshalb auch den Koffer des LKW voll gebraucht habe. Auch die Spannung eines einzelligen Lipos ist zu gering für einen Mikrocontroller wie er mir vorlag.

    Eingebaut habe ich nun folgendes:
    1x Arduino Nano ohne pins
    1x step-up voltage booster 5V
    1x Bluetooth module
    1x Goteck 1083 Servo
    1x M700 Getriebe von sol expert
    1x Lenkachse von sol expert
    1x 1 Cell Lipo mit 300 mAh
    1x L293D Motortreibe IC
    einige Leds sowie Widerstände in 150, 300 und 510 Ohm.
    Kilometerweise Kabel und Kupferlackdraht...

    Gesagt getan habe ich erstmal versucht eine geeingete Bluetooth-App im Google Play store zu finden.
    Leider gab es da wirklich garnichts was einigermaßen vernünftig aussah oder irgendwie für meine Zwecke gut geeignet war.
    Also habe ich mir eine eigene Controller App geschrieben.
    Diese ermöglicht es nun entweder eine automatische Rückwärts/Vorwärts umschaltung zu verwenden oder über einen dedizierten Knopf den "Rückwärtsgang" einzulegen und dann ganz fein zu steuern.
    Auch die Lichtfunktionen konnte ich so schön auf eigene Buttons platzieren. Eine erweiterung bzw. anpassung an spätere Modelle schau ich mir dann nochmal genauer an.

    Nachdem die Grundzüge der Bedienung fertig waren, habe ich meinen Arduino programmiert und die Befehle aus der App aud die Fahrbefehle umgesetzt. Nachdem dies am prototyp funktioniert hat, habe ich den LKW umgebaut.
    Leider hat sich mein Wiking LKW nicht so einfach umbauen lassen, wie ich mir das vorgestellt habe. Diesen Teil des Projektes habe ich sehr unterschätzt. Auch das Löten von 0402 Leds ist mir wirklich schwer gefallen, da ich nur eine große Lötspitze zur Hand hatte. Ich glaube die Front habe ich 2 oder 3 mal unter Fluchen mit neuen Leds bestückt weil sie doch im Nachhinein nicht (oder nicht mehr... ) geleuchtet haben.

    So sieht die App bis jetzt aus:


    Nunja,.. nach vielen Stunden im Bastelkeller und ein paar schönen Hörbüchern, möchte ich euch gern meinen Zwischenstand präsentieren.
    Was noch fehlt ist der Umbau des Anhängers sowie (falls noch platz im Koffer ist) der einbau einer Anhängerkupplung über linear Servo.
    Vielleicht baue ich auch noch einen Extender akku in den Anhänger ein aber das ist noch nicht klar.

    Hier ein paar Impressionen vom Bau:
    Ich habe zuerst versucht ein 6g Servo einzubauen aber das hat nicht so recht passen wollen.
    Als das ultra mikro Servo kam wurde mir erst klar wie klein es noch geht :)


    Grundausstattung des Chassis:






    Meine nächsten Versuche sind nun das ganze mit eigenem Mikrokontroller so klein zu bekommen, das es in etwa die größe des größten RX empfängers hat. Jedoch kann ich die Platine nur einseitig Layouten weil die Bluetootmodule so groß sind und ich nicht an die Firmware dieser Module ran komme um es selbst zu bauen...
    Auch die Verkabelung meines Projektes hat noch viel Potential, da ich einfach alle Kabel direkt in den Koffer gelegt habe ohne diese nochmals zu kürzen. Da könnte man noch viel Platz sparen.

    Ich habe jetzt mal die Bilder mit der addPics.com seite hochgeladen... ich hoffe das stimmt so..

    Bisschen Warnblinken gehört auch dazu.


    genau so wie der Rückwärtsgang


    Und noch ein bisschen der Blick nach innen... ist mir fast ein bisschen peinlich aber es ist eben der Prototyp :)




    Was meint Ihr zu meinem Projekt?

    Viele Grüße, Tobi


    |addpics|nmr-1-143e.jpg-invaddpicsinvv,nmr-2-2402.jpg-invaddpicsinvv,nmr-3-f146.jpg-invaddpicsinvv,nmr-4-0016.jpg-invaddpicsinvv,nmr-5-5493.jpg-invaddpicsinvv,nmr-6-e358.jpg-invaddpicsinvv,nmr-7-db55.jpg-invaddpicsinvv,nmr-8-b1aa.jpg,nmr-9-5933.jpg-invaddpicsinvv,nmr-a-c2d0.jpg-invaddpicsinvv|/addpics|

Inhalte des Mitglieds Tobey
Beiträge: 14

Xobor Forum Software von Xobor
Einfach ein eigenes Forum erstellen
Datenschutz